Kwasowa Grota Heroes VIIMight & Magic XDark MessiahHorn of the AbyssHistoria Światów MMSkarbiecCzat
Cmentarz jest opustoszały
jesteś zalogowany jako Nieznajomy
zaloguj się    załóż konto
Niebiańska Kuźnia  (WoG, HotA, VCMI)temat: Intro przy starcie WoG
komnata: Niebiańska Kuźnia (WoG, HotA, VCMI)

yojo2 PW
24 listopada 2007, 18:17
Czy jest możliwość usunięcia intra, które jest pokazywane przy starcie WoG? Po jego odgraniu w całym systemie mam zniekształcony dźwięk (nie wiedzieć czemu). Standardowe intro z SoD nie powoduje takich problemów.
Jakieś pomysły?

tymolord PW
24 listopada 2007, 19:37
Możesz poszukać ResEditem pliku z filmami i go usunąć, ale nic nie obiecuje, czy się coś nie spaprze.

CKM PW
24 listopada 2007, 19:40
Wątpie że to intro powoduje zniekształcenie dźwięku, podejrzewałbym raczej że to urochomienie WoG-a powoduje zniekształcenie dźwięku.

Nemomon PW
24 listopada 2007, 19:46
tymolord:
Możesz poszukać ResEditem pliku z filmami i go usunąć, ale nic nie obiecuje, czy się coś nie spaprze.

Musiałby jeszcze dokładnie wiedzieć które pliki, ponieważ jak usuniesz wszystkie dźwięki z folderu MP3, to w grze i tak parę ich występuje. Przypuszczam, że gra może się spaprać właśnie po usunięciu tych plików. Przy okazji CKM, pamiętasz może jaki prezent otrzymał sebolol z okazji zmiany nicka?

Acid Dragon PW
24 listopada 2007, 20:24
Cytat:
Czy jest możliwość usunięcia intra, które jest pokazywane przy starcie WoG?

Właściwie nie.

Cytat:
Po jego odgraniu w całym systemie mam zniekształcony dźwięk (nie wiedzieć czemu). Standardowe intro z SoD nie powoduje takich problemów.
Jakieś pomysły?

Błąd musi leżeć gdzie indziej, gdyż taki błąd przy poprawnie zainstalowanym WoGu na poprawnie działających systemach po prostu nie występuje i nigdy nic podobnego nie było zgłaszane.

yojo2 PW
24 listopada 2007, 22:30
Acid Dragon:
Błąd musi leżeć gdzie indziej, gdyż taki błąd przy poprawnie zainstalowanym WoGu na poprawnie działających systemach po prostu nie występuje i nigdy nic podobnego nie było zgłaszane.
Założyłem, że ten błąd powoduje intro, gdyż zniekształcenie dźwięku rozpoczyna się dokładnie w momencie rozpoczęcia jego odgrywania (jest to wyczuwalne gdy w tle puszczę sobie jakąś muzykę - dopóki jest czarny ekran przy uruchamianiu dopóty dźwięk brzmi normalnie). Oczywiście efekt zniekształcenia pozostaje aż do restartu komputera.
Właściwie to zapomniałem o tym wspomnieć, ale kiedyś miałem podobny problem - przy oglądaniu filmów dźwięk był zniekształcony. Już nie pamiętam co było przyczyną. Teraz w każdym razie nie ma takich problemów w systemie, ale w WoGu jest (albo pozostał - być może kiedyś też się dźwięk zniekształcał, ale nie słuchałem muzyki i nie dostrzegałem różnicy).

Jesli to coś pomoże, to parę info: WoG 3.58f, dodatki: Polskie Czcionki, Spolszczenie, Normal H3 Icons, Standard SoD Trees. System Windows 2000 SP4, kodeki ffdshow.

Acid Dragon PW
24 listopada 2007, 22:40
Żaden z wymienionych elementów, ewentualnie poza systemem nie powinien mieć żadnego globalnego wpływu na dźwięk. Plik intro WoGa jest plikiem typu smk (albo bik, nieważne) i do jego odtwarzania wykorzystywana jest ta sama biblioteka, co do wszystkich tego typu filmików w H3. Nie ma więc związku z kodekami. Wniosek z tego taki, że Twój system najprawdopodobniej źle interpretuje poprawną bibliotekę.

Sugerowałbym ściągnięcie nowych sterowników do karty dźwiękowej.

Tarnoob PW
25 listopada 2007, 11:27
Ja mam podobny problem – raz uruchomiłem WoGa. I co słyszę? Cienki, irytujący pisk… Odpaliłem SoD, tam też nie działa muzyka. Gdzie może tkwić problem? Nie modyfikowałem zawartości katalogu mp3.

Acid Dragon PW
25 listopada 2007, 11:35
proponuję to samo rozwiązanie.

Względnie, jeśli Twój system to Vista, to proponuję wyrzucenie go do kosza ;P.

avatar PW
25 listopada 2007, 11:37
Intra wcale nie trzeba usuwać, wystarczy odpalić grę z odpowiednim parametrem, a intro zostanie pominięte. Tak można było w każdej części H3, więc w WoGu zapewne też. Zabijcie mnie, ale.... nie pamiętam jaki to był parametr...
Chyba coś takiego:
heroes3.exe /I -??
heroes3.exe \I -??
heroes3.exe /S -??
heroes3.exe \S -??

yojo2 PW
25 listopada 2007, 12:04
Acid Dragon:
Sugerowałbym ściągnięcie nowych sterowników do karty dźwiękowej.
No z tym to może być problem, bo mam sterowniki z roku 2000 i zdaje się żadnych nowszych nie ma. Karta to ALS100+, rocznik 1998.
avatar:
Intra wcale nie trzeba usuwać, wystarczy odpalić grę z odpowiednim parametrem, a intro zostanie pominięte. Tak można było w każdej części H3, więc w WoGu zapewne też. Zabijcie mnie, ale.... nie pamiętam jaki to był parametr...
Hm, próbowałem coś wygooglować i nic nie znalazłem o żadnych parametrach, więc może być z tym problem. A podane przez Ciebie parametry nic nie zdziałały, chyba, że coś źle robię.
Jeszcze coś pokombinuję, ale jak ktoś zna odpowiedź to się nie obrażę ;)
temat: Intro przy starcie WoG

powered by phpQui
beware of the two-headed weasel