Kwasowa Grota Heroes VIIMight & Magic XDark MessiahHorn of the AbyssHistoria Światów MMSkarbiecCzat
Cmentarz jest opustoszały
jesteś zalogowany jako Nieznajomy
zaloguj się    załóż konto
Niebiańska Kuźnia  (WoG, HotA, VCMI)temat: [ważne] ERA - wtyczki, łatki, sprawy ogólne i techniczne
komnata: Niebiańska Kuźnia (WoG, HotA, VCMI)
strona: 1 - 2 - 3 ... 13 - 14 - 15

Szaman PW
10 grudnia 2017, 16:13
Przydał by się tutaj "ambasador/herold" ERY2. Polskie podwórko ERY2 jest strasznie niezadbane:)

Twórca ERY2(Bersy) zaktualizował ERE2 do wersji 2.6.5. W której naprawiono pewnie bugi np:

-Randomowe crushy przy wejściu opcjach wogach.
-Niektóre jednostki otrzymały nowe zdolności.
-Opcje WoG można z panelu mod managera ustawiać.
-Dodano możliwości(mod) szybkiego zapisania (ctrl+S)
-Poprawiono panel mod managera (bardziej szczegółowo opisuje dany mod teraz).
-Usprawniono Edytor map.
-Jest kompatybilna z najnowszymi wersjami HD moda.
-Dodano nowe składnie ERM.




Kuririn PW
10 grudnia 2017, 17:16
Szamanq, mógłbyś opisać "nowe" zdolności stworzeń?

Szaman PW
10 grudnia 2017, 22:15
Trochę przesadziłem:P jest tylko jedna dodatkowa zdolność dla krasnoludów;)
-Krasnoludy mają zdolność Hammer bash (mogą ogłuszyć przeciwnika na jedną turę).

Planuje wypuścić swoją paczkę z dodatkowymi zdolnościami dla różnych oddziałów;)

avatar PW
10 grudnia 2017, 22:49
Ogłuszyć, czyli...? Jak w praktyce to się objawia?

Szaman PW
11 grudnia 2017, 22:49
Potrzebny tłumacz do ERY2:) Nowa wersja jest nie-kompatybilna z modem WoG Polish. Wystarczy przetłumaczyć dwa pliki txt: zcrexp i znpc00.

Szaman PW
6 stycznia, 02:51
ERA (2.7.0) dostała mały update, acz bardzo istotny i zadziwiający. Bersy, idzie w kierunku VCMI i w najnowszej wersji obsługuje skrypty LUA (to te same skrypty co wykorzystuje VCMI?)...
Oczywiście ERM nadal działa, ale autor ERY nie przewiduje już pisania nowych skryptów.

Link

Czyżby ERM odchodzi do lamusa?

avatar PW
6 stycznia, 09:14
Nie, nie, nie ;] VCMI nie ma skryptów. jsony to jeszcze coś innego.
Natomiast wersja alfa woga 3.59 rozwijana kiedyś przez GrayFace'a działała już na skryptach Lua a nie ERM. Podobno to łatwiejszy język i do nauczenia się i bardziej uniwersalny.

A z tego co wyczytałem to Bersy próbuje dodać obsługę wielu typów plików graficznych. Jeśli doda obsługę grafik z przezroczystością, to fred79 jeszcze odmieni tę grę do niepoznania!!!

Warmonger PW
6 stycznia, 09:31
Jeśli skrypty lui działają, to jest to istotnie przełom!

Choć potrzebny jest jeszcze pełen zestaw funkcji dostępnych dla użytkownika, a wiele komend ERM trudno przetłumaczyć w sensowny sposób na konwencjonalne języki.

zmudziak22 PW
8 stycznia, 00:20
LUA można się nauczyć choćby na przykładzie Heroes 5, tam jako tako dało się ogarnąć jak skrypt mapy działał.

Warmonger PW
8 stycznia, 09:21
Sam od tego zaczynałem, więc tym bardziej jestem rozczarowany tym, co Bersy pokazał. Nie ma żadnego gotowego API, jest tylko kod do ręcznego manipulowania adresami i pamięcią -.-.

Dydzio PW
8 stycznia, 21:04
Szaman:
ERA (2.7.0) dostała mały update, acz bardzo istotny i zadziwiający. Bersy, idzie w kierunku VCMI i w najnowszej wersji obsługuje skrypty LUA (to te same skrypty co wykorzystuje VCMI?)...

Nie żebym był specjalnie czepialski, ale zastanawiam się, czemu Szaman w różnych tematach komentuje / ocenia / porównuje z erą np vcmi, podczas gdy chyba nie wie za bardzo z czym to się obecnie je. Polecam sprawdzić nowy dzienny build jeśli ktoś tego nie zrobił od paru miesięcy - by obiektywnie oceniać fanowskie projekty najlepiej jest się z nimi trochę lepiej zapoznać i też nie bazować na ich przestarzałych wersjach - od czasu np 0.99 minął ponad rok i fixnięto 100+ bugów.
strona: 1 - 2 - 3 - 4 - 5 - 6 - 7 - 8 - 9 - 10 - 11 - 12 - 13 - 14 - 15
temat: [ważne] ERA - wtyczki, łatki, sprawy ogólne i techniczne

powered by phpQui
beware of the two-headed weasel